Page 3 of 3 FirstFirst 123
Results 31 to 33 of 33

Thread: 42RLE Transmission Won't Drive

  1. #31
    Join Date
    Dec 2003
    Location
    North Phoenix
    Posts
    8,389

    Re: 42RLE Transmission Won't Drive

    Update?
    Quote Originally Posted by amber.hodge View Post
    Steve is so innocent. Its really cute, actually. Ah to be a kid again....
    "anyone who says they know everything about anything is either a fool or a liar"

  2. #32
    Join Date
    Mar 2008
    Location
    Ahwatukee
    Posts
    404

    Re: 42RLE Transmission Won't Drive

    I towed it to the dealer for a diagnostic testing. I didn't want to drop the transmission to only find out with was some kind of electrical issue. They don't know for sure, but thinking the transmission pump failed. I'm going to drop the transmission this week. Now I just need to figure out if I just want to swap the pump or go for a full rebuild.

  3. #33

    Re: 42RLE Transmission Won't Drive

    if the pump failed there is likely debris in the trans, you need to tear it down and inspect!

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 15 users browsing this thread. (4 members and 11 guests)

  1. FourxDad,
  2. Jim Friedrich,
  3. OlneyJeeps,
  4. wranglerwill01

Similar Threads

  1. 2006 TJ 4.0 & 42RLE automatic transmission
    By aribelin in forum Engines, Transmissions, and Transfer Cases
    Replies: 13
    Last Post: 02-16-2016, 09:14 PM
  2. 42RLE Transmission Updates ?????
    By Crasher in forum General Discussion
    Replies: 1
    Last Post: 08-08-2014, 04:44 PM
  3. Help drive shaft rubs transmission!
    By Telanas in forum General Discussion
    Replies: 17
    Last Post: 06-15-2009, 09:47 AM
  4. 42rle transmission filter
    By mbuckner in forum General Discussion
    Replies: 3
    Last Post: 11-27-2006, 09:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •