Results 1 to 8 of 8

Thread: Well, there's your problem...

  1. #1

    Well, there's your problem...

    Notice anything missing? Axle side of the rear upper control arms. Both sides were like that. I have no idea how long I've been driving it that way, but it does explain the clunk when I back up. Fixed now.

    Sent from my Pixel XL using Tapatalk

  2. #2
    Join Date
    Sep 2006
    Location
    Mesa
    Posts
    3,168

    Re: Well, there's your problem...

    bolts are so over rated...
    82 Cherokee WT SOA/SF/high steer/Alcan springs/agr box/Borgeson steering shaft/AMC 401/performer/holley TA/HEI/BeCool/727/ALTAS (2.0/2.72/5.44)/D60 Snofighter(Yukon Zip,hubs,stubs,4.56)/14 Bolt (FF,BF shave, Discs, ARB,Artec Truss)/MTR 37X12.5/Corbeau Moab Seats/RCI 6point Harness/Hella Aux lights/tuffy console/killer32 sliders/custom bumpers and roll bar/WARN 8000/steering brace/CO2 Tank/CB/dual batts/custom TC skid plate

  3. #3
    Join Date
    Jan 2014
    Location
    Anthem
    Posts
    665

    Re: Well, there's your problem...



    It pays to crawl under there once in a while. Good find!

  4. #4
    Join Date
    Sep 2017
    Location
    Mesa
    Posts
    165

    Re: Well, there's your problem...

    is that rust or mud all over?

  5. #5

    Re: Well, there's your problem...

    Surface rust mostly, it spent 12 years in NY and MA. I've gone over the entire frame with a hammer looking for weak spots and it seems ok, but there are a couple of rotten spots on the tub and fender. I broke one bolt and had to cut off two bolts getting the lower control arms off.

    Sent from my Pixel XL using Tapatalk

  6. #6
    Join Date
    Sep 2017
    Location
    Mesa
    Posts
    165

    Re: Well, there's your problem...

    good thing you live here now LOL. Nice and dry.

  7. #7
    Join Date
    Oct 2014
    Location
    tucson az
    Posts
    138

    Re: Well, there's your problem...

    Looks ok to me...

  8. #8

    Re: Well, there's your problem...

    Put the new bolts in with nylock nuts. They should stay in place this time.

    Sent from my Pixel XL using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. AC problem
    By djui5 in forum General Discussion
    Replies: 5
    Last Post: 07-15-2008, 04:17 PM
  2. '97 TJ A/C Problem?
    By RalphA in forum General Discussion
    Replies: 4
    Last Post: 05-04-2007, 10:28 PM
  3. Problem with 98 ZJ
    By ROKCRLR in forum General Discussion
    Replies: 22
    Last Post: 01-19-2007, 07:57 AM
  4. Replies: 10
    Last Post: 02-20-2004, 01:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •