Results 1 to 2 of 2

Thread: Electrical Mess

  1. #1
    Join Date
    Aug 2006
    Location
    Mesa, AZ
    Posts
    2

    Electrical Mess

    I have a 1989 Jeep XJ and a 1994 Jeep XJ. I decided to degrease the engine compartment. Big Mistake! Now on both of my Jeeps the airconditioning, turn signals, brake lights, hazard lights, windshield wipers, and radio will not work. I replaced some fuses but I still can't get the anything to work. I checked the fusible links and there is power after the link. I took apart the wiring harness at the firewall and it is dry. I put di-electric(sp) grease on the connections and it still won't work. The engine runs and I can drive both of them. Does anyone know if there is a module or relay that needs to be replaced? The repair manuel is useless.

  2. #2
    Join Date
    Oct 2005
    Location
    Peoria
    Posts
    207

    Re: Electrical Mess

    The same things happened on my xj...but like a day later everything started working again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Electrical Mess.
    By Jeep Huancayo in forum General Discussion
    Replies: 1
    Last Post: 08-10-2006, 08:25 PM
  2. Yahoo Messages: 78935-78959
    By blooddrive in forum Virtual Jeep Club Email Archive
    Replies: 0
    Last Post: 01-08-2004, 05:10 AM
  3. Yahoo Messages: 78835-78859
    By blooddrive in forum Virtual Jeep Club Email Archive
    Replies: 0
    Last Post: 01-07-2004, 10:53 PM
  4. Yahoo Messages: 78810-78834
    By blooddrive in forum Virtual Jeep Club Email Archive
    Replies: 0
    Last Post: 01-07-2004, 10:52 PM
  5. 8020-8044
    By blooddrive in forum Virtual Jeep Club Email Archive
    Replies: 0
    Last Post: 01-02-2004, 08:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •