PDA

View Full Version : Anyone on the west/northwest side have a tranny jack?



Big Will
11-04-2009, 10:32 AM
Something we horribly wrong this morning on the way to work, heard a popping coming from the tranny area, would pop more consistant when I speed up, then pow one big pop and she wouldn't move, engine runs and I can here a slight popping grinding sound from the tranny so I either did something to the tranny or my garage clutch job failed, she moves if I push her but I can put it in gear without engaging the clutch and it does nothing, so I'm assuming it's my clutch or the bolts that held the clutch or flywheel in place. I did this job with a floor jack and it was a HUGE pain, would prefer to borrow a tranny jack if someone in the area has one. Won't need it till next week as my jeep has perfect timing, my garage is full of furniture cause I'm having new floors put in the house at the moment. Thanks in advance if you can help me!!

vin man
11-04-2009, 10:43 AM
I'm not on your side of town, but if nothing pans out for you, you can borrow mine. This is the one I have:

http://www.harborfreight.com/cpi/ctaf/displayitem.taf?Itemnumber=39178

I work in Tempe at about I-10 and Warner and could bring it to work.

Big Will
11-04-2009, 11:36 AM
Thanks Vin Man, I may have to take you up on that if I can't find one. I work off the 10 and 43rd Ave so I can hit the freeway and be in Tempe within a half hour or so. If I can't come up with one on the west side I'll definately be in touch, thanks!

knockonit
11-04-2009, 12:49 PM
I've got the same one from HF, am up around 20th st and greenway,
ric

Big Will
11-04-2009, 03:01 PM
Ric, that might be closer for me, I'm off of 43rd Ave and Cactus. I'll definately be in touch, ned my poor jeep, wonder if it had anything to do with me beating the cr@p out of it this weekend out in Wickenburg.

fatbob
11-04-2009, 04:00 PM
Did you check your u-joints?

Big Will
11-05-2009, 09:27 AM
Not yet, haven't had a chance to climb under there, I am almost hoping the clutch was just bad so I can replace it for free. But yeah considered that something else in there could have broke like the TC or something, but the noise sounds like it's coming from the tranny area, I'm almost afraid it could be the flywheel bolts.

D.Glorp
11-19-2009, 09:46 PM
There are adjustments on the sides of the door. Look for bolt heads.

It is either that or you installed something wrong. I cant imagine that the sides are out of adjustment....so check your installation.

Big Will
11-20-2009, 03:24 PM
I pushed it into the garage yesterday, makes all kids of noise just rolling, wondering now if I broke the rear end, either way should find out this weekend.